Topics Covered: Phones/Endpoints Not Registering, Softphones Not Registering and SIP Trunks Not Registering
PHONES / ENDPOINTS NOT REGISTERING
Common Causes
- SIP ALG or Firewall Blocks
- DHCP or Option 66 Setup Incorrectly - This prevents a phone from getting an IP address.
- Network Connectivity
Troubleshooting Steps/Solutions
SIP ALG or Firewall Blocks- Check to see if SIP ALG or SIP Transformation is enabled on any device passing SIP traffic. If so, disable both settings and retest.
- Check to see if the firewall is manipulating SIP traffic.
- Peer the phone by directly connecting to the edge device or modem to rule out network segments.
- DHCP Server or Option 66 Setup incorrectly
- Make sure the phone is getting an IP address. If the phone is not getting an address, check the connection to the DHCP Server. If the phone is getting the correct address, then check the Option 66 string for that subnet.
- To confirm an Option 66 problem, manually set up the phone and plug it in behind the modem.
- Network Connectivity
o Make sure the phone can reach the public internet. - Connect a laptop to the phone PC port and try to connect to the internet.
- For newer phones you can run ping and trace commands from the phone.
SOFTPHONES NOT REGISTERING
Common Causes
- Mobile Network Connectivity - Typically occurs when carrier being used for data is blocking:
- SIP ALG or Firewall Blocks
- Incorrect Authentication Information
- Troubleshooting Steps/Solutions
- Mobile Network
o Check with the carrier being used for data and make sure that SIP and UDP are supported and not blocked.
o Register the device off-network to ensure server connectivity is good. - SIP ALG or Firewall Blocks - These settings commonly cause problems registering softphones on Wi-Fi networks.
- Check to see if SIP ALG or SIP Transformation is enabled on any device passing SIP traffic. If so, disable both settings and retest.
- Check to see if the firewall is manipulating SIP traffic.
- Run Test My Connection (test.sipregistration.com) to check for blocked firewall ports.
- Incorrect Authentication Information
- Make sure the SIP username and password are correctly entered in the application you are using.
- Reset the SIP Password for the extension in the portal.
SIP TRUNKS NOT REGISTERING
Common Causes
- Incorrect Programming
- No Communication to Edge or Registrar Device
- Incorrect Authentication Information
- Troubleshooting Steps/Solutions
Incorrect Programming
- Verify that the SIP Trunk Hostname, Username, and Password are correctly entered in thePBX.
- Check with the PBX manufacturer to confirm the correct settings.
- Check the Simplicity Knowledge base for posts with SIP Trunk installation instructions.
- No Communication to Edge or Registrar Device - In some cases the PBX will not handle Registrar Messaging and will commonly be behind an Edgemarc or Adtran that is connected to a PRI.
- Verify that the Registrar device is actually registered. If it is, then verify the PRI connection between the device and the PBX is working. o Check PBX log data to determine the cause of failure over the PRI.
Incorrect Authentication Information
- Verify the authentication information is entered in the proper fields, or the device will never register. Generate a new password.
- Replace the hostname with the corresponding IP address.
- Try to register the trunk information on a softphone application to verify authentication information and connectivity to Simplicity.
- Test for this condition by changing the context Registration Type from “SIP Proxy” to “Feature Server.”
- Contact Simplicity VoIP Client Services if this condition exists for assistance with correcting the problem.
Note: Do not permanently change this setting, because it may disable future geo-redundancy capabilities.